Announcement

Collapse
No announcement yet.

I have recently developed a serious new problem in my left eye, please help

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I have recently developed a serious new problem in my left eye, please help

    Full length title: Hello, I have a crippling aqueous deficiency dry eye for~2 years now, nobody seems to know why, I recently seem to have developed a new problem, painful aching in or near where the lacrimal gland is in my left eye and possibly dryness(at least it was extra dry for a while)

    I have serum drops, restasis, 4x plugs, also have steroids prescribed for when it gets really bad if it's of any relevance. Also, in my left eye(the one affected) I think there may be a punctal plug pushed in there, one that isn't meant to be inside but outside. Now I have another one outside it, maybe the first plug could cause this)

    If I recall correctly, it all started a bit more than a month ago, my eye became more red than usual, in a manner that reminded me of when I got what I believe was a minor bacterial infection, all over red but not extremely RED, still white but more red all over.

    With this redness came an aching pain and very much more dry, it was very bad for around 2 weeks but then started to get a bit better, but I was still in much pain and this thing really put me out of action for like a month. I think the dryness was not as noticeable after few days or perhaps up to 2 weeks, I don't remember very well.

    I only went to the doctor when it was mostly better but seemed to get worse for a few days there which worried me enough to go to the doctor, by the way I really should have gone from the start but was so sick of going to the doctor for eye problems at the time which was stupid.

    He said my eyes looked good, the only thing he could see was that there was minor inflammation (and irritation I don't remember?) of the lacrimal gland, the area near it is red.


    I did get antibiotic drops from him just in case, I thought maybe I had a bacterial infection, I asked him if my aching pain was just from dryness, he said he doesn't know.

    I did take the antibiotic drops for like 4-5 days then stopped because I guess if the doctor didn't think I have bacterial infection then why bother, I didn't take them regularly after that but occasionally which may have been stupid I know, I still have a few of them I think I will take the rest. I don't know if they worked, after taking the drops I imagine my eyes feel good but ache continues later on.

    I still have aching pain, it's a bit better now but I have not seen much improvement lately and it's still pretty bad, if I use my eye too much it starts aching badly so I can't use it too much.

    One thing I'd like to mention is that my eyes are most dry on top, gravity makes the liquid go down and pool up because of my plugs, but my lacrimal glands don't produce much and I get much of my liquid from drops so there's not a whole lot on the top of my eye.

    Please, advice, information, help, what is wrong with my eye, why is it aching in or near the lacrimal gland, why is it inflamed, what can I do?

    I guess I will go see a doctor again, but maybe someone here can offer some valuable help as well? Don't just tell me to go see a doctor!

    Also some point there was extra goo and those gooey strings in my eyes you know?, not much but some, it stopped as it started getting better. I have gotten those before when other problems with my eyes but usually don't have them, was definitely connected to this.

    My own thoughts recently are that maybe it was/is a viral infection, what do you think of that?

    Thanks

  • #2
    Hi this sounds similar to me I posted only yesterday in the open forum under the title 'is my dry eye caution unexplainable eye pain' or something like that it's a few posts up from this one feel free to read it as I go into a lot of detail and let me know if it's the same symptoms as yours?!
    We might be able to help eachother

    Comment

    Working...
    X

    Debug Information